[Bug 678] New: System inappropriately suspends with no GUI app present

bugzilla-daemon at bugzilla.openmoko.org bugzilla-daemon at bugzilla.openmoko.org
Wed Aug 1 23:17:32 CEST 2007


           Summary: System inappropriately suspends with no GUI app present
           Product: OpenMoko
           Version: unspecified
          Platform: Neo1973
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Applications & Dependencies
        AssignedTo: mickey at vanille-media.de
        ReportedBy: mjr at iki.fi
                CC: buglog at lists.openmoko.org

Couldn't really decide which component to blame of those listed, as power
management and related stuff isn't separated. So I put it here, move if appropriate.

Anyway, it appears that OpenMoko will suspend the Neo within about five minutes
if there are no GUI apps (sans the top panel) running. This with no regard to it
being plugged in, and usbnet being in active use. Also playing music in the
background with ogg123 will not prevent suspend.

To reproduce, kill the today app by pushing the power button while it's up, then
kill the task manager similarly, if necessary with a little aid from tapping the
graphical quarter-wheel at the left of screen. After this, suspension will be

(I first thought that this was an USB or usbnet issue, and reflected this on the
device-owners list; this was in fact not the case in the end, in case someone
was wondering.)

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the buglog mailing list