[Bug 256] GSM Modem doesn't seem to work on some devices (no serial communication possible)

bugzilla-daemon at bugzilla.openmoko.org bugzilla-daemon at bugzilla.openmoko.org
Sat Aug 25 17:23:29 CEST 2007


andreas at bawue.net changed:

           What    |Removed                     |Added
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

------- Additional Comments From andreas at bawue.net  2007-08-25 17:23 -------
Unfortunately, it seems that current 2007.2 snapshots on my device have this
problem as a regression:

root at fic-gta01:~$ lsof | grep ttySAC0
root at fic-gta01:~$ echo "1" > /sys/bus/platform/devices/gta01-pm-gsm.0/power_on
root at fic-gta01:~$ dmesg | tail -n 6
<6>gta01-pm-gsm gta01-pm-gsm.0: powering up GSM, thus disconnecting serial console
<7>modem wakeup interrupt
<4>adc_read: entering (pcf=c07d9c00, channel=0, data2=00000000)
<4>pcf50606_irq: entering(irq=53, pcf=c07d9c00): scheduling work
<4>pcf50606_work: INT1=0x40 INT2=0x00 INT3=0x01:SECOND ADCRDY 
<4>adc_read: returning 715 0
root at fic-gta01:~$ chown uucp.uucp /dev/ttySAC0
root at fic-gta01:~$ cu -l /dev/ttySAC0

>From that point on, the terminal is dead.

I've gotten the modem to work in the past and even had the dialer doing dialout
once but since trying the newer updated images it's a no go.
Although there was no message about "AT-Command Interpreter Ready" during the
manual tries the device answered OK to ATZ.

The problem manifests itself with todays snapshot as well.

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the buglog mailing list