[Bug 321] New: ftdi_eeprom often fails silently

bugzilla-daemon at bugzilla.openmoko.org bugzilla-daemon at bugzilla.openmoko.org
Thu Mar 29 04:39:11 CEST 2007


           Summary: ftdi_eeprom often fails silently
           Product: Debug Board
           Version: Version 2
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: critical
          Priority: P2
         Component: default component
        AssignedTo: werner at openmoko.org
        ReportedBy: werner at openmoko.org
                CC: laforge at openmoko.org

Trying to change the EEPROM content with ftdi_eeprom (under Linux) often
yields no or only partial results. In all those cases observed so far,
ftdi_eeprom indicated that the operation was *successful*, even though
the result was not as expected.

So far, I (Werner) have the following three cases:
- prototype series board: USB IDs do not change
- end-of-March board: USB IDs do not change
- another end-of-March board: USB IDs change, strings are not set

Apparently, Nils Faerber experienced the same kind of problem. On the
other hand, Harald said that he programmed several boards without such
problems, so this bug may depend on external factors.

The ID change can be verified as follows:
- program the board
- unplug USB
- re-plug USB
- lsusb -d 0x1457:
  should print something like this:
  Bus 002 Device 057: ID 1457:5118  

The strings are best observed with usbview, which will show a lot of
question marks where the name of the device and its manufacturer should

I'll gather more data to get a clearer picture of what's going on here.

------- You are receiving this mail because: -------
You are on the CC list for the bug, or are watching someone who is.

More information about the buglog mailing list