Openmoko Bug #1718: python-pygtk programs don't work

Openmoko Public Trac bugs at
Fri Aug 1 16:48:22 CEST 2008

#1718: python-pygtk programs don't work
 Reporter:  Mercury  |       Owner:  julian_chu 
     Type:  defect   |      Status:  new        
 Priority:  normal   |   Milestone:  ASU        
Component:  Distro   |     Version:  unspecified
 Severity:  normal   |    Keywords:             
 Blocking:           |   Blockedby:             
 I tried installing python-pygtk to run a script someone had written, but
 it (and all other pygtk scripts) fail out with this error:


 Traceback (most recent call last):
   File "./", line 14, in <module>
     import gtk
   File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/", line
 82, in <module>
 NameError: name 'init' is not defined


 The error seems to be indicating that the problem is during the
 initialization of the gtk stuff.

 I'm using the ''
 feed and I ran opkg upgrade today and it didn't help.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list