Openmoko Bug #666: 3G SIM capability

Openmoko Public Trac bugs at
Wed Aug 6 17:20:42 CEST 2008

#666: 3G SIM capability
 Reporter:  steven.demetrius at  |        Owner:  michael    
     Type:  defect                      |       Status:  new        
 Priority:  highest                     |    Milestone:             
Component:  GSM Modem                   |      Version:  unspecified
 Severity:  critical                    |   Resolution:             
 Keywords:  SIM att 7300g 71234 4022    |     Blocking:             
Blockedby:                              |  

Comment(by Kev):

 Same problems as ChaosEagle here with the O2 German Card (Picture:, A new card
 (the newest one from O2) has the same pin layout and didn't work, too. It
 seems that 80-90% of the problematic cards have the same layout, with this
 big spaces at the bottom of the chip and the round connectors.

 Something interesting is written on the german wikipedia

 The first sim-voltage was 5V, later 3V and the newest one have 1.8V. The
 1.8V Card does also work with 3V so the new card could be used on old
 phones, but the 3V Card can not operate at 1.8V, so the old card does not
 work on new phones.

 According to
 the chipset used in the Neo operates at 4V, that means that it can not
 work with the very first simcards (5V) but there seems also to be a
 problem with the newest 1.8 V cards. Could there be a bug that prevents
 1.8V cards from working in the neo correct?
 Has anyone a 1.8 V simcard that is working properly?

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list