Openmoko Bug #1756: Qtopia GUI (qpe) broken after 'opkg upgrade'

Openmoko Public Trac bugs at
Thu Aug 7 13:30:50 CEST 2008

#1756: Qtopia GUI (qpe) broken after 'opkg upgrade'
 Reporter:  aeneby  |       Owner:  zecke      
     Type:  defect  |      Status:  new        
 Priority:  high    |   Milestone:             
Component:  Qtopia  |     Version:  GTA02v5    
 Severity:  major   |    Keywords:  Qtopia, qpe
 Blocking:          |   Blockedby:             
 After running 'opkg update' and 'opkg upgrade' on a fresh Qtopia 4.3.2
 GTA02 image, qpe will no longer load. The qpe init script
 (/etc/init.d/qpe) enters an infinite loop trying to start/restart qpe, and
 the qpe process terminates with the following error:

 qpe: symbol lookup error: /opt/Qtopia/lib/ undefined
 symbol: _ZN11QListWidget9dropEventEP10QDropEvent

 This bug is reproducible by installing Qtopia and running the upgrade.
 Looks like a broken ABI after something changed in the upgrade?

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list