Openmoko Bug #1756: Qtopia GUI (qpe) broken after 'opkg upgrade'

Openmoko Public Trac bugs at
Sat Aug 9 04:07:40 CEST 2008

#1756: Qtopia GUI (qpe) broken after 'opkg upgrade'
 Reporter:  aeneby       |        Owner:  openmoko-devel
     Type:  defect       |       Status:  assigned      
 Priority:  high         |    Milestone:                
Component:  Qtopia       |      Version:  GTA02v5       
 Severity:  major        |   Resolution:                
 Keywords:  Qtopia, qpe  |     Blocking:                
Blockedby:               |  

Comment(by yarikoptic):

 I want to complement to lpotter's words: /opt is commonly used in
 distributions to carry 3d party applications, ie which are not a part of
 the distribution. Thus indeed native qtopia is shipped 'correctly' by
 lpotter under /opt. OM  does provide a distribution, thus it would be much
 better if none of the OMs packages installs under /opt, but rather uses
 /usr/ hierarchy (e.g. /usr/lib/qtopia).
 That can help to avoid similar issues in the future.

 For users to resolve the situation if you want to run native qtopia:
 1. remove all qtopia packages installed from OM's repositories:
 opkg list_installed | awk '{print $1;}' | xargs opkg remove
 NB typing from memory thus could be incorrect. you might also need to
 force removal disrespecting dependencies

 2. to make sure that all libraries links are reincarnated correctly --
 reinstall /opt/Qtopa using freshly provided "binary update" script

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list