Openmoko Bug #1697: [Battery] No Alert message when battery is low

Openmoko Public Trac bugs at
Tue Aug 12 01:16:04 CEST 2008

#1697: [Battery] No Alert message when battery is low
 Reporter:  regina_kim   |        Owner:  raster  
     Type:  enhancement  |       Status:  assigned
 Priority:  high         |    Milestone:  Om2008.9
Component:  E - Illume   |      Version:          
 Severity:  minor        |   Resolution:          
 Keywords:  pm           |     Blocking:          
Blockedby:               |  

Comment(by raster):

 ok - reason why "config" is involved:

 the battery gadget is e's own default battery meter - the same one i see
 on my laptop. same code. exact same thng. it just has a different theme in
 illume (on ASU). that exact same code ALREADY can pop up a warning dialog
 if the battery reaches X percent or Y minutes left until empty. that code
 has been there for years now. that is configured to be DISABLED in ASU.
 there is a configuration dialog to enable/disable this and set the time or
 percentage at which to show it. the problem is that ASU is set up in such
 a way that the mechanism that has existed for years to do just this is not
 available to a user. so there is no need to "add" a dialog... it's already
 there! (in ASU it doesn't have a nice theme - but it would work... if you
 could turn it on). so to me this is a design issue as design wanted to be
 very particular about exactly what configuration is available and how. all
 the existing code E has had for years and infrastructure to expose this
 and make it accessible to users has been ignored, so i can't really do
 much. (the start of the whole exposure thing. must be in python etc. etc.
 i made a point of this but it was not my call) :)

 i probably need to say "i told you so" in that life will just get harder
 and everything be more and more work the more design tries to fight
 against existing infrastructure and code. :(

 anyway - as for battery going red - that is possible. it's just part of
 the theme. but as design is to be pixel perfect, until design specifies a
 red battery - i can't do it, as it's not specified in the design :(

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list