Openmoko Bug #1814: Broken mplayer package dependenties

Openmoko Public Trac bugs at
Wed Aug 13 00:28:15 CEST 2008

#1814: Broken mplayer package dependenties
 Reporter:  lock    |       Owner:  julian_chu                                 
     Type:  defect  |      Status:  new                                        
 Priority:  normal  |   Milestone:                                             
Component:  Distro  |     Version:                                             
 Severity:  normal  |    Keywords:  mplayer, libxv, libmp3lame0, broken package
 Blocking:          |   Blockedby:                                             
 I use repository and tray install
 mplayer (opkg install mplayer). Mplayer package install properitly, but
 after executing mplayer command i get:

 mplayer: error while loading shared libraries: cannot open
 shared object file: No such file or directory

 so, i install ldd tool, and check what else is missing:

 root at om-gta02:~# ldd `which mplayer` => not found => /usr/lib/ (0x40031000) => /usr/lib/ (0x4003e000) => /lib/ (0x400bf000) => not found => /usr/lib/ (0x4017e000) => /usr/lib/ (0x401c1000) => /usr/lib/ (0x401e8000) => /usr/lib/ (0x40200000) => /usr/lib/ (0x40225000) => /lib/ (0x402ec000) => /usr/lib/ (0x402f7000) => /usr/lib/ (0x40367000) => /usr/lib/ (0x40397000) => /lib/ (0x403b4000) => /lib/ (0x40462000) => /lib/ (0x40474000) => /usr/lib/ (0x40593000) => /usr/lib/ (0x4067d000)
         /lib/ (0x40000000) => /usr/lib/ (0x40693000) => /usr/lib/ (0x406b8000) => /usr/lib/ (0x406c2000)

 I fix'ed that installing packages (libxv1 and libmp3lame0) from angstrom- But if mplayer package is in official repository
 dependent packages must be also and must be installed automaticaly.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list