Openmoko Bug #1267: Strong echo when calling a Neo from another phone

Openmoko Public Trac bugs at
Fri Aug 15 23:12:06 CEST 2008

#1267: Strong echo when calling a Neo from another phone
 Reporter:  mail at  |        Owner:  sean_chiang
     Type:  defect             |       Status:  assigned   
 Priority:  high               |    Milestone:             
Component:  Audio              |      Version:  unspecified
 Severity:  normal             |   Resolution:             
 Keywords:  audio, echo        |     Blocking:             
Blockedby:                     |  

Comment(by degraffenried):

 I have tried the attachment above and copied it to
 /usr/share/openmoko/scenarios/gsmhandset.state on my freerunner, but it
 didn't work. The next step I tried was adjusting settings in the program
 alsamixer while on a call. The best way to do this is to log into the
 phone from a desktop or laptop and call alsomixer so you have a large
 screen. I adjusted the volume of the item labeled Mono until the person on
 the other line could still hear me fine, but didn't get an echo when they
 talked, and this also solved a problem with the buzzing that they heard
 (ticket []). This does not keep
 the settings for the next call, so I learned to change the
 gsmhandset.state file - there is only one entry I had to play with until I
 got it right. I changed control.5 ('Mono Playback Volume') to have the
 value 85. Try a few more settings to see if you can clear it up any more.
 I don't know if this solves the issue completely - but it helped me quite
 a bit - and perhaps helps lead to a better solution.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list