Openmoko Bug #1897: OM2008.8-upgrade

Openmoko Public Trac bugs at
Thu Aug 28 23:56:25 CEST 2008

#1897: OM2008.8-upgrade
 Reporter:  Yorick   |          Owner:  zecke   
     Type:  defect   |         Status:  new     
 Priority:  highest  |      Milestone:  Om2008.9
Component:  Qtopia   |        Version:  Om2008.8
 Severity:  blocker  |       Keywords:  PIN     
Blockedby:           |   Reproducible:  always  
 Blocking:           |  
 PIN dialog does not show up:
 I have a fully upgraded 2008.8-upgrade, and have not changed the feeds.

 Since I didn't get any luck with the qtopia dialer I installed the
 So I should delete one of the dialers?

 I rebooted 2008.8 and the PIN dialog doesn't show up so when I try the
 qtopia-dialer it says of course no network...

 After opening openmoko-dialer2 I try to call and get the error message
 "Method "Dial" with signature "s" on interface
 "org.openmoko.PhoneKit?.Dialer" doesn't exist". Immediatly after this
 error message I get a new sms message (strange, no? i'm still not
 registered) and immediatly after this message the pin dialog of openmoko-
 dialer2 shows up.
 My network icon says I have good reception (green) but when I press Dial,
 it says "Dialer Error: No Network".

 I close openmoko-dialer2.

 I open the qtopia-messages and I see no new message...

 I close qtopia-messages.

 I open qtopia-dialer
 I dial my number
 It says (Dialing) but I hear no sound and my speakers also do not respond
 like they do when I dial.

 I press disconnect.

 I once again try openmoko-dialer2 in vain.

 Logread and opkg list_installed is attached.

 I then uninstalled openmoko-dialer2
 No pin-dialog
 opened qtopia-dialer
 dialed and got of course the no network not registered thing
 re-opened qtopia-dialer
 same result
 gave it up and did logread and lsit_installed

 (I googled but couldn't find the commands to force the PIN dialog...)

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list