Openmoko Bug #666: 3G SIM capability

Openmoko Public Trac bugs at
Fri Aug 29 19:57:54 CEST 2008

#666: 3G SIM capability
 Reporter:  steven.demetrius at  |        Owner:  michael    
     Type:  defect                      |       Status:  new        
 Priority:  highest                     |    Milestone:             
Component:  GSM Modem                   |      Version:  unspecified
 Severity:  critical                    |   Resolution:             
 Keywords:  SIM att 7300g 71234 4022    |    Blockedby:             
 Blocking:                              |  

Comment(by Eorhim):

 OK, I will join the circus.

 I spent some time submitting AT commads and all network- and
 authentication-related commands failed
 ( Especially the AT+CPIN
 failed every time. I first tested it with the GUI and it told me after
 three times, my SIM is now locked, but after switching to an other phone
 it was still working without requiring the PUC. I'm not sure, who's
 responsible for locking a SIM, but I think it should be the SIM itself.

 So my conclusion is: The FreeRunner has problems submitting the PIN
 (perhaps comunicating relyable with the SIM alltogether).

 Then I switched off the PIN usage with the other phone, but nothing
 changed in the behavior. The same with switching the PIN to 0000 and an
 other value.

 I also tried the "insert SIM card slightly awry", but it didn't help.

 Operator: O2 Germany
 SIM serial: 7080643993750VY UMTS/GSM SIM

 I got the SIM card at the beginning of August 2008. No voltage indicator,
 unless the 50V in the number indicate the voltage, but that's unlikely.
 Layout is the reported problematic one.

 I did all my tests with 2007.2 of 2008-08-20 and no additional software.
 The gsm_log output is attatched.

 I will test the SIM card of a friend (operator T-Mobile Germany) later
 this evening.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list