Openmoko Bug #1905: packagekit daemon crashing due to interactive pacakge install?

Openmoko Public Trac bugs at
Fri Aug 29 21:45:55 CEST 2008

#1905: packagekit daemon crashing due to interactive pacakge install?
 Reporter:  peepsalot  |          Owner:  tick    
     Type:  defect     |         Status:  new     
 Priority:  normal     |      Milestone:          
Component:  Installer  |        Version:  Om2008.8
 Severity:  normal     |       Keywords:          
Blockedby:             |   Reproducible:          
 Blocking:             |  
 I tried running pkcon update on my my freerunner.

 It displayed many lines of installing packages, then suddenly quit when it
 got to openmoko-community-repository :

 installing   openmoko-common2-0.1.0+svnr3259-r0   [===============] (74%)
 installing   openmoko-community-repository-1.0-r0.01[               ]
 The daemon crashed mid-transaction!

 I did "killall packagekitd" and tried the upgrade again through opkg.

 This time when it got to that same package there was a interactive prompt:

     Configuration file '/etc/opkg/Multiverse-feed.conf'
     ==> File on system created by you or by a script.
     ==> File also in package provided by package maintainer.
        What would you like to do about it ?  Your options are:
         Y or I  : install the package maintainer's version
         N or O  : keep your currently-installed version
           D     : show the differences between the versions (if diff is
      The default action is to keep your current version.
     *** Multiverse-feed.conf (Y/I/N/O/D) [default=N] ?

 If I remember correctly from some short reading I've done about
 packagekit: interactive installs are not supported, so I'm guessing that's
 why it crashed.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list