Openmoko Bug #1024: gsm modem oscillating between registrated / not-registrated

Openmoko Public Trac bugs at
Wed Dec 31 09:37:38 CET 2008

#1024: gsm modem oscillating between registrated / not-registrated
    Reporter:  mickey@…             |        Owner:  sean_chiang
        Type:  defect               |       Status:  in_testing 
    Priority:  high                 |    Milestone:             
   Component:  gsmd                 |      Version:  unspecified
    Severity:  blocker              |   Resolution:             
    Keywords:                       |     Haspatch:  0          
   Blockedby:                       |    Estimated:             
 Patchreview:                       |     Blocking:             
Reproducible:                       |  

Comment(by pb0):

 It looks like I have the same problem even with the newest QT extended
 (4.4.2) and the latest om image 2008.12. I upgrade firmware from Moko8 to
 Moko10. Neo keeps registration only for several seconds. Due this the
 outgoing call is impossible and incoming ring only once (or ever). Then
 phone is unregistered and registered again. Tested with 4 T-mobile SIMs
 and with one brand new O2 SIM with the same behaviour. I tested it with
 libgsmd-tool and directly with AT commnads (output is attached).
 Should be the problem caused by something else then deep sleep?
 Can I run any other command to be the problem allocated?
 Anyway it looks like the problem is HW related. The phone should be
 replaced with other one by local reseller, shouldn't?

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list