Openmoko Bug #1267: Strong echo when calling a Neo from another phone

Openmoko Public Trac bugs at
Sat Jul 12 09:52:44 CEST 2008

#1267: Strong echo when calling a Neo from another phone
 Reporter:  mail at  |        Owner:  sean_chiang at
     Type:  defect             |       Status:  assigned                
 Priority:  high               |    Milestone:                          
Component:  Audio              |      Version:  unspecified             
 Severity:  normal             |   Resolution:                          
 Keywords:  audio, echo        |     Blocking:                          
Blockedby:                     |  

Comment(by danielmewes):

 I am using the Neo1973 with ASU and modified the
 /ust/share/openmoko/scenarios/gsmhandset.state to the attached state file
 and was able to strongly reduce (however not totally eliminate) the echo
 and also generally increasing the sound quality.

 I do not remember what exactly I changed, but a diff should reveal this.
 As far as I remember regarding the echo I especially had to change:
 1. Mono 2 Mux from Inverted Mono 1 to Right
 2. Mono Sidetone Playback Volume to 0 (interestningly, there is still some
 sidetone on the Neo. Perhaps both the modem and the sound card generate

 But I am not sure if those changes are sufficient or I changed another
 important thing (just went through the mixer while a call was on and tried
 to change nearly every control). Please look into the attached file, if
 this alone should not help.

 This however is more a dirty-but-working-hack, since I did not look into
 how the sound is actually wired inside the Neo and what exactly all the
 controls are meaning.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list