Openmoko Bug #1841: white screen of death (WSOD) after resume

Openmoko Public Trac bugs at
Wed Nov 26 04:06:42 CET 2008

#1841: white screen of death (WSOD) after resume
    Reporter:  Rorschach    |        Owner:  openmoko-devel
        Type:  defect       |       Status:  new           
    Priority:  highest      |    Milestone:                
   Component:  unknown      |      Version:  GTA02v5       
    Severity:  critical     |   Resolution:                
    Keywords:  wsod,resume  |     Haspatch:  0             
   Blockedby:               |    Estimated:                
 Patchreview:               |     Blocking:                
Reproducible:  always       |  

Comment(by nicolas.dufresne):

 Ok, I think we are very close to a solution. I've disable deep sleep in
 the JBT driver, checked the suspend still works for the rest of the driver
 (around 20 sleep, unsleep), put it to sleep, put it in the freezer for 20
 minutes, took out and waked up, no WSOD. I've put back the unpatched
 kernel, did same thing, got a WSOD. There is definitely something wrong
 about this driver.

 From that point without the datasheet (under NDA) it will be hard to
 continu, and to make sure we doing things right. Whatever how bad the
 datasheet are (as mentionned on the dev mailing list), the ones who has it
 will figure out the bug quicker than me. I'm going to post my patch, so
 other people can reproduce. Note that I have no idea what effect this
 patch may have on power consumption or anything else you could think of.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list