Openmoko Bug #1939: wifi crashes the device

Openmoko Public Trac bugs at
Tue Oct 21 15:06:55 CEST 2008

#1939: wifi crashes the device
    Reporter:  gawlitza  |        Owner:  marek       
        Type:  defect    |       Status:  assigned    
    Priority:  normal    |    Milestone:  Om2008.9    
   Component:  unknown   |      Version:  Om2008.9-dev
    Severity:  major     |   Resolution:              
    Keywords:            |    Blockedby:              
Reproducible:  always    |     Blocking:              

Comment(by chenna):

 I have flashed the device with Om2008.8.uImage.bin  &
    available at

 I could not find the file /etc/volatives.cache but I could find
 /etc/volatile.cache and deleted this file and rebooted. But still I see
 wIFI unknown.

 I have seen the ticket 1734 and there  I found th following info:

 I could not locate openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806

 Please share the working image for WIFI, USB networking and Blue tooth.

 Please let me know the path where to download the working image for WIFI,
 USB networking and Bluetooth.


 Replying to mattt:

 Just in the interest of completeness, I reflashed the old rootfs...

 still using the 20080808 kernel.

 wifi works
 usb works
 carrier is detected.

 So I don't think it's the kernel.
 And it isn't he hardware.

 Replying to [comment:6 marek]:
 > Currently, we are digging into the wifi stuff to debug the driver.
 Om2008.8 has problems with unsecured networks as well but we could trace
 it down. I think we can fix that one soon. We move on to WEP networks now.
 We will come up with an instruction to narrow down the issue. I guess
 Werner will post it somewhere. We highly appreciate your help.
 > My mail address (marek at should work - others can mail me.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list