Openmoko Bug #1024: gsm modem oscillating between registrated / not-registrated

Openmoko Public Trac bugs at
Fri Sep 5 10:51:39 CEST 2008

#1024: gsm modem oscillating between registrated / not-registrated
 Reporter:  mickey at  |        Owner:  sean_chiang
     Type:  defect               |       Status:  assigned   
 Priority:  high                 |    Milestone:             
Component:  gsmd                 |      Version:  unspecified
 Severity:  blocker              |   Resolution:             
 Keywords:                       |    Blockedby:             
 Blocking:                       |  

Comment(by akriegisch):

 same problem for me with all kinds of software (2007.2, 2008.8 and now
 I tried 4 different 3G sim cards with the same result. (I seem to be
 unable to get any 2G cards) Here is an example session from mickeyterm:
 => (removed empty lines)
 +CREG: 2
 +CREG: 1,"00B5","4B72"
 +CREG: 0
 +CREG: 1,"00B5","7320"
 +CREG: 0
 +CREG: 1,"00B5","4B72"
 +CREG: 0
 +CREG: 1,"00B5","4B72"
 +CREG: 0
 have about 0.5 to 2 "CREG: 0" per minute ad infinitum)

 several other strange things I noticed:

 * once I saw "CME ERROR: 321" (with OM2007.2 in libgsmd-tool -m shell at
 the very beginning of SIM/GSM initialization) which is especially
 interesting as cm_E_ error 321 does not exist -- just cm_S_ error 321?

 * my freerunner is gta02v6 (with gps capacitor already in place at sd
 socket when I got it) and still needs more than 10 minutes to get First
 Fix. (mine looks like -- I
 know this is GPS and not GMS, but I wonder if there is any relation
 between stuff like that just because the accepted solution does not seem
 to work for me.

  +CGMR: "HW: GTA02BV5, GSM:
 list my FR as GTA02BV5 whereas /proc/cpuinfo gives:
   Hardware        : GTA02
   Revision        : 0360
 and using boot prompt on serial console says GAT02v6:
     In:    usbtty
     Out:   usbtty
     Err:   usbtty
     Unrecognized hardware revision 0x305. Defaulting to GTA02v6.
     PCB rev: 0x305
     Power: 0mA
     GTA02v6 # version

     U-Boot 1.3.2+gitr650149a53dbdd48bf6dfef90930c8ab182adb512 (Sep  3 2008
 - 10:20:46)
 IMO this is the most recent U-Boot version that should know about my
 Freerunner's version, right?

 * I noticed a better reconnect to gsm behavior on OM2007.2 right after
 installing and using gsm0710muxd. Before at some point (about after 10-15
 minutes) phone never really registered again.

 * When calling the FR the line drops immediately -- the second time works
 most of the time (ie: wait until after registration of FR completes, call
 FR, FR will immediately get "CREG: 0" instead of the call, FR reconnects,
 call FR again -> bell rings...)

 * After having a connection (no matter if in- or outbound) it is stable
 most of the time. Just roaming between cells does not work reliably due to
 this issue.

 I will gladly help by providing any information necessary for further
 debugging and can even offer root shell to the device if anyone is
 interested?! Will gladly try alpha & beta GSM firmware! :-) [sadly right
 now the phone is unusable for me... :-/]

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list