Openmoko Bug #2268: Alignment trap: Xglamo

Openmoko Public Trac bugs at
Fri Apr 10 19:40:28 CEST 2009

#2268: Alignment trap: Xglamo
 Reporter:  xbaldauf  |          Owner:  openmoko-devel
     Type:  defect    |         Status:  new           
 Priority:  normal    |      Milestone:                
Component:  unknown   |        Version:  unspecified   
 Severity:  normal    |       Keywords:                
 Haspatch:  0         |      Blockedby:                
Estimated:            |    Patchreview:                
 Blocking:            |   Reproducible:                

 from time to time, I experience alignment traps on my Freerunner,
 involving various binaries. I'm not sure whether this is a result of a bug
 in the software which is trapping, a bug in the kernel I'm running
 (2.6.29-GTA02_stable-t-mokodev) or a hardware defect. This time, Xglamo
 crashed, but the remaining system remained stable.

 root at om-gta02:~# dmesg | grep Xglamo
 [ 5116.140000] Alignment trap: Xglamo (1510) PC=0x40283fc4
 Instr=0xe5846008 Address=0xfc610007 FSR 0x803
 root at om-gta02:~# md5sum $(which Xglamo)
 3ddb5f186f92e6a6f56eb923732bf7dc  /usr/bin/Xglamo
 root at om-gta02:~#

 I have not yet found a reliable way to reproduce this type of bug.
 I know that it may be hard to analyze this bug (given this little
 information), but maybe other people who have the same problem gravitate
 to this ticket and can contribute useful information.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list