Openmoko Bug #1743: Intenso SDHC 4GB gives glamo errors

Openmoko Public Trac bugs at
Tue Dec 1 17:57:18 CET 2009

#1743: Intenso SDHC 4GB gives glamo errors
 Reporter:  beni     |          Owner:  openmoko-devel
     Type:  defect   |         Status:  closed        
 Priority:  normal   |      Milestone:                
Component:  unknown  |        Version:                
 Severity:  major    |     Resolution:  fixed         
 Keywords:           |      Blockedby:                
 Blocking:           |   Reproducible:                

Comment(by skliarie):

 I did "dmesg | grep glamo" and attached the result to this email.

 I also tried to do
 cd /sys/module/glamo_mci/parameters/
 echo 10000000 > sd_max_clk
 echo 3 > sd_drive

 But still got the following after "cat /dev/zero > /sdcard/zero":

 <6>[  255.795000] glamo-mci glamo-mci.0: Error after cmd: 0xc120
 <3>[  255.795000] mmcblk0: error -110 sending read/write command, response
 0x0, card status 0x400900

 I then tried to do
 echo 5000000 > sd_max_clk
 and got no more sdcard errors! The write speed was acceptable 2.800

 Is there a way for the kernel to automatically detect such "slow" cards as
 I have and adjust the clock rate correspondingly?

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list