Openmoko Bug #2215: distros using fso-gsm0710muxd will not register

Openmoko Public Trac bugs at
Fri Jan 23 08:33:26 CET 2009

#2215: distros using fso-gsm0710muxd will not register
 Reporter:  BillK            |          Owner:  openmoko-kernel      
     Type:  defect           |         Status:  new                  
 Priority:  normal           |      Milestone:  FSO                  
Component:  System Software  |        Version:                       
 Severity:  normal           |       Keywords:  gsm0710muxd GSM modem
 Haspatch:  0                |      Blockedby:                       
Estimated:                   |    Patchreview:                       
 Blocking:                   |   Reproducible:  always               
 I have never been able to register to a carrier with the gsm0710muxd
 Ive tried 4 vodafone SIMs - one ~7-8 yrs old, others between a year or two
 One Telstra 3g grey sim purchased 22/01/2009

 All work in 2007.2 (3 of the vodafone sims), and 2008.x - none work with
 the mux, even on 2008.x if I use the mux as per the wiki.

 Appearance is that the mux never receives any data after sending the first
 wakeup and just goes silent.
 attached is a logread, frameworkd.log and ophoned.log

 The distro here is shr-lite from unstable downloaded 23/01/2009 with the
 latest fso-gs0710muxd (9.3) built today (but results are identical no
 matter what distro I use with any version of the mux).  I modified it here
 to permanently turn on verbose messages for the logread as I couldnt get
 shr to do so using the -v argument.

 Results are identical with a standard gsm0710muxd using the -v argument -
 no matter what distro or version of the mux.


Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list