Openmoko Bug #2254: No usb pressed/released event with 2.6.28/2.6.29

Openmoko Public Trac bugs at
Sun Mar 8 12:42:15 CET 2009

#2254: No usb pressed/released event with 2.6.28/2.6.29
 Reporter:  Defiant  |          Owner:  openmoko-devel                    
     Type:  defect   |         Status:  new                               
 Priority:  normal   |      Milestone:  FSO                               
Component:  unknown  |        Version:  unspecified                       
 Severity:  normal   |       Keywords:  usb event4 2.6.28 pressed released
 Haspatch:  0        |      Blockedby:                                    
Estimated:           |    Patchreview:                                    
 Blocking:           |   Reproducible:                                    

 Hardware: Freerunner
 Distribution: Debian (but kernel issue)

 With the 2.6.24 kernel in Debian I always got an event when inserting or
 removing the usb plug.

 With the current 2.6.28 in debian I no longer get this event.

 I also tried the andy-tracking-15ca3dafb2662db4 2.6.29 from 7.3.2009, no

 I tried with
 hexdump /dev/input/event4

 I guess this is a bug and not an intended change?
 If you need additional information please let me know.

Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list