Openmoko Bug #2257: gsm0710muxd: "Modem does not respond to AT commands"

Openmoko Public Trac bugs at
Tue Mar 10 04:05:14 CET 2009

#2257: gsm0710muxd: "Modem does not respond to AT commands"
 Reporter:  lindi            |          Owner:  openmoko-kernel
     Type:  defect           |         Status:  new            
 Priority:  normal           |      Milestone:                 
Component:  System Software  |        Version:  unspecified    
 Severity:  normal           |       Keywords:                 
 Haspatch:  0                |      Blockedby:                 
Estimated:                   |    Patchreview:                 
 Blocking:                   |   Reproducible:                 

Comment(by BillK):

 Sounds similar to bug #2215 - the description is somewhat misleading when
 I raised it :(

 moko11 didnt fix it for me - still had to tweak the code in gs0710muxd and
 use an external script get it to talk - works reliably with current shr-
 testing with my changes to the mux - never worked with any gsm0710muxd
 version or the original, moko10 and now moko11 firmware tried until the
 changes were made.  distros *NOT* using the mux work, though not as well
 as my current setup.

 Is there any more work on the kernel driver side coming? - in 2.6.29
 perhaps?  Saw some things awhile back that made me think "thats will solve
 it" :)


Ticket URL: <> <>
openmoko trac

More information about the buglog mailing list