avoid auto power-off in u-boot mode

Javi Roman javiroman at kernel-labs.org
Wed Aug 22 12:53:28 CEST 2007

On 8/22/07, Javi Roman <javiroman at kernel-labs.org> wrote:
> The entry http://wiki.openmoko.org/wiki/Flashing_openmoko#Preparing_the_device_for_DFU_mode
> warns us about some devices turns off after a period of inactivity
> while on the u-boot menu.
> I am not really sure if this issue is hardware related, because the
> same behavior happens when we use QEMU to go into u-boot: If you log
> into u-boot by means of "telnet localhost 1200", the system power-off
> passed a few seconds, therefore is difficult to work under these
> conditions.
> Is it possible to avoid this nuisance?
> Regards,
>         -Javi

Answer my own question:

Setting the environment variable boot_menu_timeout = number_of_seconds
solves the problem.

GTA01Bv4 # setenv boot_menu_timeout 10000


More information about the community mailing list