2007.2 compilation failed with package uicmoc4-native-4.0.3

mickeyl at linuxtogo.org mickeyl at linuxtogo.org
Thu Aug 23 11:27:01 CEST 2007

From OpenMoko-community:

Rod Whitby wrote:
> Phani Kumar Kancharala wrote:
>>  Hi all,  
>>     I followed the steps in wiki-openmoko to get openmoko on my pc
>> running Ubuntu 7.04 Feisty Fwan. Finally I also ended up with the same
>> error reported by *Frank Gau, *following are the error and logs given by
>> the mokomakefile:
>> | kernel/qapplication_x11.cpp:89:31: error: X11/extensions/XI.h: No such
>> file or directory

> Install the host software package which provides the XI.h file.

> It'll be some X11 extensions development package.

> Then update the OEAndYourDistro page on the openembedded wiki to
> highlight that package as a requirement for your host distro.

Hmm, since when is uicmoc-native requiring X? If I recall correctly, I
had always chosen to build the respective -embedded variant of Qt to
not impose the need of having X on the build machine. It looks like we
are now building qt-x11 as provider for uicmoc4. Why did we change that?

- Michael Lauer <mickey at openmoko.org>                   http://openmoko.org/
Software for the worlds' first truly open Free Software mobile phone

More information about the community mailing list