Battery time

John Locke mail at
Fri Nov 9 05:27:05 CET 2007


I was running Qtopia for 5 or 6 weeks, and under that, I was getting
about 5 hours of time tops, whether I used the phone or not. The battery
indicator has 5 bars, and after a good 4 hours, there would still be 3
bars left (60%, or so you might think). But by that point, the power
dropped very quickly and the phone would just shut off.

I managed to flash OpenMoko on the Neo last weekend, even with my broken
Aux button (had to take off the faceplate and carefully hold the contact
in place, but managed to do it...). I just now got in after having it
unplugged for 7 hours, and the battery still shows mostly full. I had
set the power management to "Dim Only", and with that alone OpenMoko
seems to be doing much better than Qtopia. I also notice that the phone
is not so hot--Qtopia seems to have it running full power almost all the

Other notes:

Qtopia (Image from around October 7)
* Phone seems to stop working after a few days, and needs to be
rebooted. There's no indication when this has happened--you just can't
make or receive calls anymore.

* Rebooting didn't actually work--I nearly always had to remove the
battery to reboot.

* There was a delay in audio switching, both on outgoing and incoming
calls. I never heard the first few words people answered with--I had to
start talking when I heard the audio switch, without knowing whether I
had actually reached the right person. You never heard a remote line
ring--the audio would switch after the call was answered, whether by a
person or voicemail.

* SMS is beautiful, when the message arrives when the phone was on.

* There's no voicemail indicator--but I received empty text messages
when there was a new voicemail, and again after clearing the message.

* Phone numbers on the SIM card showed up in the address book.

* You can't redial a number or pick a number out of the call history to
dial (I think it assumes you have a hard button for that).

* Dialing a number in the address book works fine, though the button to
do it is hard to press with a finger (most other things in Qtopia worked
easily without the pen)

* You get an echo sound at first, but can use alsamixer to turn down the
sidetone and then the phone sounds perfectly normal.

* No mediaplayer, feed reader, or all the other cool stuff that's in

* Keyboard auto-completes far too easily (and wrong most of the time)
but the zoom keys are actually usable with fingers.

* No terminal. Ugh.

* GPRS doesn't work. Didn't get my bluetooth headset working, either.

* Ring profiles work great--easy to switch between vibrate only and
audible ring.

OpenMoko (Scaredycat image from November 1)
* I get frequent messages indicating that it's just associated with the
GSM network.

* No audible ring, vibrate only.

* Panel crashes about once a day, necessitating a reboot.

* Rebooting works (if the Today application hasn't crashed).

* OS still seems less stable, everything still seems to crash more than

* Audio switches immediately, much more normal for making and receiving
calls--you hear the phone ring at the other end.

* No SMS, or voicemail indicator.

* Much easier to dial, hang-up, do other basic calling tasks.

* Dialing from history works.

* Dialing from address book mostly works, but not if there's punctuation
in the phone number (I copied my Evolution addressbook over, and most of
the entries don't work unless I strip out dashes/parentheses)

* Haven't tried GPRS or Bluetooth yet.

* Sound quality has a bad echo--haven't found the appropriate sidetone
control in Alsamixer yet.

* Mediaplayer has come a long way! If I could get it to seek within a
track, it would be all I need.

* Keyboard is very difficult to use with fingers alone. In general, you
need the pen more with OpenMoko.

All in all? I'd have to say I like using OpenMoko better, it acts more
like a normal phone, the battery life seems more reasonable (though I
haven't run it long enough to tell you more about battery life). But I'm
still having the sidetone issues, no ringer, and it still seems to crash
a little too much. And the lack of SMS is a bit of a problem, since I
get pages from my servers (though it's nice and quiet without it!) And a
recent update hosed most of the menu, so I can't get to the feedreader
or terminal at the moment...


Oliver Uvman wrote:
> Hi!
> So for the longest time, I've been worrying about the battery life of
> the Neo. Before I buy the GTA02, it is something I'd love to know. The
> wiki has entries talking about which power management things are
> implemented and which aren't, and I assume this will increase over
> time. On the iPhone page, the Battery row of the table says 8h talk on
> iPhone and "replaceable 1.7 Ah battery charged via USB" on the Neo -
> not very extensive info.
> So, since many of you seem to have Neos now, and since the dialer app
> is (supposedly) working now, how's the phone for real-world usage? How
> long between charges for *you*? What do *you* do with it during
> "normal usage"?
> Cheers,
> Oliver
> ------------------------------------------------------------------------

John Locke
"Open Source Solutions for Small Business Problems"
published by Charles River Media, June 2004

More information about the community mailing list