Some feedback from using the neo as a phone for a day

Mark Arvidson sagacis at
Wed Oct 17 03:05:38 CEST 2007

I too have tried using the phone as a primary for a few days.
Recently, the lack of 850 band coverage has driven me to my backup.
Perhaps I'll try again tomorrow.

I have some parallel observations and comments to Igor's:

On 10/14/07, Igor Foox <igorfoox at> wrote:
> Voice/Talking:
>     - I tried playing with sidetone in alsamixer but that didn't help,
> so I don't think that that's the problem.
I worked on different settings and got something that works well in a
room or in the car.  The one in right now has micrphone mixed
with the incoming call, which makes usage in my car impossible.  I'll
see if I can isolate the changes that made it work for me.  Also,
there's a bug for this already:

> UI:
> - The current keyboard is highly unusable. I know it's intended to be
> used with a stylus, and it's fine for that, but it's completely
> unreasonable to expect a user to have a stylus for activities like
> SMS, or entering a new contact. And even with pretty small fingers
> it's pretty hard for me to type on the keyboard.

I totally agree.  I can sometimes hit the right key with my
fingernail, but backspace is difficult.  The keys also have quite a
bit of dead space between them, so you have to hit it right on.

> - The scrolling is very cool, but it's often difficult to scroll when
> the items you're scrolling are clickable, because it incorrectly gets
> recognized as a click.

I'm constantly launching one of the games when I just want to scroll
down to the terminal.

> - The dialer application has the "hangup" button on the top right of
> the screen when in a call. When you actually talk on the phone it's
> _really_ easy to touch that part of the screen with your face, which
> results in 3-4 accidental hangups per call. Oops. :-)

Same here.  Maybe I need to shave closer.

> - The "status" icons on the top tend to disappear once in a while.
> Sometimes a reboot gets them back. Sometimes it doesn't. But usually
> two or three reboots get them back. Very perplexing. :)

At one point, the Battery applet was causing this, but I don't know any more.

I'll send an update in the next day or two with more observations on my part.

More information about the community mailing list