libidn build fails in the current svn head

Sudharshan S sudharsh at
Sun Sep 16 14:34:20 CEST 2007

Hello everyone,
I man having problems building libidn and would like to know if any one
has this problem and/or gotten around the same. One thing from the logs
i noticed was the fact that the build system is trying to install it
before the do_compile stage..I guess this is weird or am i mistaken.
Here are the logs,

NOTE: package libidn-0.5.19: started
NOTE: package libidn-0.5.19-r0: task do_install: started
ERROR: function do_install failed
ERROR: log data follows
| NOTE: make
DESTDIR=/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-angstrom-linux-gnueabi/libidn-0.5.19-r0/image install
| make[1]: Entering directory
| make[1]: *** No rule to make target `install'.  Stop.
| make[1]: Leaving directory
| FATAL: oe_runmake failed
NOTE: Task
failed: /home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-angstrom-linux-gnueabi/libidn-0.5.19-r0/temp/log.do_install.31536
NOTE: package libidn-0.5.19-r0: task do_install: failed
ERROR: TaskFailed event exception, aborting
NOTE: package libidn-0.5.19: failed
ERROR: Build
of /home/sudharsh/Projects/openmoko/openembedded/packages/gpephone/ do_install failed
ERROR: Task 2854
(/home/sudharsh/Projects/openmoko/openembedded/packages/gpephone/, do_install) failed
NOTE: Tasks Summary: Attempted 1555 tasks of which 1543 didn't need to
be rerun and 1 failed.
'/home/sudharsh/Projects/openmoko/openembedded/packages/gpephone/' failed
make: *** [openmoko-devel-image] Error 1

Sudharshan S

More information about the community mailing list