new package pango-directfb-1.18.1-r0 requires latest Glib 2.14.x

TTZ W ttzweb at
Tue Sep 25 18:29:12 CEST 2007

My build failed last night with the following error:

| checking for CAIRO... yes
| checking for cairo_surface_write_to_png in -lcairo... yes
| checking for cairo_ps_surface_create in -lcairo... yes
| checking for cairo_pdf_surface_create in -lcairo... yes
| checking for cairo_xlib_surface_create in -lcairo... no
| checking for cairo_win32_scaled_font_select_font in -lcairo... no
| checking for cairo_ft_scaled_font_lock_face in -lcairo... yes
| checking for cairo_atsui_font_face_create_for_atsu_font_id in -lcairo... no
| checking for GLIB... no
| configure: error:
| *** Glib 2.14.0 or better is required. The latest version of
| *** Glib is always available from
| FATAL: oe_runconf failed
NOTE: Task failed:
NOTE: package pango-directfb-1.18.1-r0: task do_configure: failed

I had had a successful build just a day ago and I tried to look this
package name, pango-directfb, up in my previoud build log and couldn't 
seem to find it.

Is this a new package introduced just during last couple days?  

It looks for Glib 2.14.x which is quite recent.  The build tree
seems to come with only glib-2.12.4.

Had anyone else seen the same problem?

Is there a doc that I can get the instructions on how I may 
insert/build a local copy of Glib 2.14.x within the build tree so
that pango-directfb can find it?

Or any way I can roll back my build tree for few days?

I am following the standard MoKoMakefile build so likely I am always 
taking in the top of the tree for each build:

OE Build Configuration:
BB_VERSION     = "1.8.8"
OE_REVISION    = "fb65084e7b2133f759923afd2fa407818c5a32d5"
TARGET_ARCH    = "arm"
TARGET_OS      = "linux-gnueabi"
MACHINE        = "fic-gta01"
DISTRO         = "openmoko"
DISTRO_VERSION = "P1-September-Snapshot-20070925"
TARGET_FPU     = "soft"

Any help would be greatlly appreciated!


More information about the community mailing list