still having trouble getting Neo to boot Qtopia from SD

ian douglas id at
Thu Sep 27 03:25:39 CEST 2007

So to recap what I've tried, that doesn't work to get Qtopia on my SD 
card and boot from SD:

I went to and 
downloaded the three files under "Qtopia for the Neo1973 Downloads", and 
unpacked them onto a 2GB microSD card, formatted as ext3:

# mount /dev/sdc1 /media/sdcard
# tar -C /media/sdcard -zxvf \
# tar -C /media/sdcard -zxvf \
# tar -C /media/sdcard/boot/ -xzvf \

... the last step of course placed the uImage file and the rootfs file 
into the SD card's /boot/ folder (there's no documentation anywhere that 
describes where else to place these, so I was guessing as I went)

# cd /media/sdcard/boot
# ln -s uImage- uImage

This, of course symlinks the uImage file since the uboot menu only needs 
a file called "uImage"

Then I ejected the SD card from my Linux box, put the SD card into my 
Neo, powered up to the uboot menu, selected 'Boot from SD', and I get 
the kernel panic I posted earlier. (relisted below)

So obviously having uImage- and 
qtopia-rootfs.2-09180703.jffs2 in the /boot/ folder isn't right, so I 
put the SD card back into my Linux box and moved the files up a level so 
they would be in the 'root' folder of the file system:

# mount /dev/sdc1 /media/sdcard
# cd /media/sdcard/boot
# mv uImage- ../
# mv qtopia-rootfs.2-09180703.jffs2 ../
# rm uImage
# ln -s ../uImage- uImage
# sync ; cd ; eject /dev/sdc1

That didn't work either... same kernel panic: (last 5 lines included here)

Waiting 5sec before mounting root device...
Root-NFS: No NFS server available, giving up.
NFS: Unable to mount root fs via NFS, trying floppy.
NFS: Cannot open root device "mmcblk0p1" or unknown-block(0,2)
Please append a correct "root=" boot option
Kernel panic - not syncing: VFS: Unable to mount root fs on 

So Piotr, could you maybe please post your bash_history for us to see 
what exactly you did, to get this going? I'd be happy to edit the wiki 
page for Qtopia on the Neo for booting from SD if I can just get this 
going -- but experimentation is just frustrating when others obviously 
have already tried Qtopia on the Neo.


More information about the community mailing list