/qtopia/ hard to "Answer"

Ole Kliemann ole-om-community-2008 at mail.plastictree.net
Sat Aug 2 00:31:07 CEST 2008

On Fri, Aug 01, 2008 at 03:29:14PM -0400, Yaroslav Halchenko wrote:
> Although the rest seems to be working quite fine, and even battery life
> is tolerable, with pure qtopia I am experiencing 1 unpleasant effect
> (which while writing this email unrolled a bit ;-)
> I am running:
> root at om-gta02:~# cat /etc/version 
> 200807100425
> root at om-gta02:~# cat /proc/version 
> Linux version 2.6.24 (mwester at blocks) (gcc version 4.1.2) #71 PREEMPT Wed Jul 16 13:45:35 CDT 2008
> not sure where to look for qtopia image specific version, but I believe
> I burnt images from the latest tarball
> qtopia-4.3.2-gta02-flash-07221045.tgz
> NB you might recall my earlier reports about kernel oopses
> Whenever I receive a call, screen changes to nice choices to accept or
> not the call, but there is 2-4 seconds delay after I press Answer and
> anything actually happens. 

I experienced that as well. Maybe more like 2 secs on my device. 

> On my first reboot I got white screen and phone was stalled... had to
> keep power button pressed for quite long before it shut down
> on the next boot it got into QT, showed "No network" and didn't react to
> any buttons on the screen (Although they blinked while being pressed,
> nothing happened. Unlock item in the bottom left didn't react to
> presses). 

I had this too one or two times. Could be that it improved with newer
versions but not sure. I'm currently using latest kernel through opkg
upgrade and Qtopia snapshot 20080801 [1].

> Then it suspended and when I resumed it back -- again
> white screen. in a few secs suspended again and then didn't react to any
> buttons (ie pow, aux) -- I had to take battery out to power it to shut
> it down to power it up again.

Could be that you suffer from the `white screen of death' [2]. I
sometimes have it when resuming from long suspend.


[1] ftp://ftp.trolltech.com/qtopia/snapshots/qtopia-opensource-src-4.3.2-snapshot-20080801.tar.gz
[2] http://lists.openmoko.org/pipermail/openmoko-kernel/2008-July/004098.html
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: not available
Url : http://lists.openmoko.org/pipermail/community/attachments/20080801/6bed90c4/attachment.pgp 

More information about the community mailing list