receiving SMS messages

Vince M. Clark vclark at
Wed Aug 6 00:09:52 CEST 2008

Are you able to send OK with the Qtopia image? I can receive but not send. Could be an issue with my provider which is T-Mobile. Haven't tested receiving in suspend vs. awake mode but will try it. 

----- Original Message ----- 
From: "Tim Coggins" <sonicated at> 
To: "List for Openmoko community discussion" <community at> 
Sent: Tuesday, August 5, 2008 4:17:09 PM (GMT-0700) America/Denver 
Subject: Re: receiving SMS messages 

I can confirm this; it's been happening for the last week or so. 


On Tue, Aug 5, 2008 at 9:36 PM, Dan Weatherill 
<plasteredparrot at> wrote: 
> I recently received my freerunner, and am enjoying it so far! 
> I have mainly been using the qtopia image from, but have 
> been regularly updating my kernel from 
> On doing some testing, I find the following: I can receive SMS messages 
> perfectly whilst the phone is on, in qtopia. Not always so well in the GTK 
> stack. 
> If the phone is in standby, and I receive a text message, the phone 
> wakes up but does not receive a text message. The person sending the 
> message does, however, receive a delivery report. This occurs in both 
> images as well. 
> If I then subsequently receive a message after the others, whilst the 
> phone is out of standby, I receive all the messages together. Hence, no 
> messages are "lost" in the ether, but it seems that messages received 
> whilst the phone is on standby are temporarily mislaid. 
> If there is any information I can provide to help you sort this please just 
> let me know. This is one of very few things preventing me using the neo 
> as a day to day phone with qtopia. 
> _______________________________________________ 
> Openmoko community mailing list 
> community at 

Openmoko community mailing list 
community at 
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list