wrong offset of mouse in landscape mode (and scummvm)

Dale Maggee antisol at internode.on.net
Wed Aug 6 19:15:22 CEST 2008

Mike Montour wrote:
> Dale Maggee wrote:
>> /bin/sh: /usr/bin/scummvm: not found
>> which is very odd, because I can type "/usr/bin/scum[TAB]", and it 
>> autocompletes to scummvm. the file is marked as executable. I can't see 
>> anything wrong.
>> does anyone have any Ideas?
> For binaries this may indicate an OABI/EABI issue. There are different 
> binary formats for ARM; Openmoko now uses EABI but binaries built for 
> other platforms may be OABI. If you have binutils you can run "readelf 
> -l <program>" and look for the "Requesting program interpreter:" line.
> If it's a shell script, then it may be a similar problem with the 
> command interpreter, e.g. if the script's first line is "#!/bin/bash" 
> but you do not have /bin/bash installed.
> p.s. I just checked the wiki page that was mentioned up-thread, and it 
> looks like it's pointing to an old package from the "2007.1" days when 
> Openmoko was using OABI binaries. There's a bitbake recipe for scummvm 
> in OE so it should be easy to build an updated package if there's not 
> one already available in the feeds.
> _______________________________________________
> Openmoko community mailing list
> community at lists.openmoko.org
> http://lists.openmoko.org/mailman/listinfo/community

installed binutils,  [Requesting program interpreter: /lib/ld-linux.so.2]

/lib/ld-linux.so.2 doesn't exist. tried symlinking it to 
/lib/ld-linux.so.3, but this gave me a pile of other errors about 
missing .so files, so I'd say you're on the right track.

looks like tomorrow's project will be setting up the mokomakefile, and 
trying to compile scummvm.


More information about the community mailing list