full-keyboard for Om 2008.08?

Dirk Bergstrom openmoko at otisbean.com
Sat Aug 9 09:04:56 CEST 2008

DooD wrote:
> The files you need to edit are under
> /usr/lib/enlightenment/modules/illume/keyboards
> I believe there is a Full-QWERTY.kbd in there, just backup the Default.kbd
> and replace it with the Full-QWERTY.kbd
> mv Default.kbd Defaultbackup.kbd
> mv Full-QWERTY.kbd Default.kbd
> /etc/init.d/xserver-nodm restart

I tried this, but I still get the standard keyboard.

Somewhere along the line I installed the illume package with the 
'qwerty' icon.  Maybe that has something to do with this?

Also, I see this interesting comment in Default.kbd:

# if the key out is in quotes - "q" for example, then this key is used for
# typing words and can be part of a dictionary match, any other key when
# pressed will end the dictionary match (u can disable dictionary
# matching in
# a layout by not having any outputs in quotes)

So, that implies that if I can just get the system to recognize 
alternate kbd files, I can turn off dictionary matching, which would 
make me rather happy.

Hmmm, waitaminnit, looking at the files in that directory, I don't think 
they control the standard 2008.08 keyboard.  I'm talking about the one 
where you flick up/down to "shift" to other layouts.

Sigh.  I guess I'm still stuck with the irritating keyboard.  What's it 

Dirk Bergstrom
openmoko at otisbean.com

More information about the community mailing list