The illume-config wrench has gone

Carsten Haitzler (The Rasterman) raster at
Thu Aug 14 01:44:42 CEST 2008

On Wed, 13 Aug 2008 14:49:05 -0700 (PDT) forestmountain
<forestmountain at> babbled:

> In the illume-config under shelfs I unmarked all options and thereby removed
> the wrench from being accessable on the shelfs. Does anybody know how to get
> the wrench back. Illume-config isn't showing as an icon and I don't know
> where illume-config saves it's configuration.

you have now just done the equivalent of "rm -rf /boot" :) - you'e not getting
it back without manually resetting your config.

yes. i know. it lets you shoot yourself in the foot. with no warning or help.
as such that config spanner was a tool i used during development so i had
access to all the config swizzle bits i REALLY needed and then at the end it was
to be removed as if it never existed. the svn package rev of illume that did
that actually was never used - an earlier one was and so there was a "hack" to
just make it not visible/usable in the theme instead.

so as such i really didn't spend any effort trying to "idiot-proof" the conifg
(don't take tha the wrong way - please!".

right now i can't do much for you but suggest you:

rm -rf ~/.e/
killall -HUP enlightenment

from the shell to get a restore back to defaults :)

and yes - i know about users being able to do this and yes there should
either be special protection around hat 1 gadget, or some other mechanism to
get it back or defaults back, should you get yourself into strife. i know! i
need to fork illume and its package/theme anyway and make a new package set that
actually brings back all these goodies (config panel, illume keyboard etc.) by
default and THEN i'll start to worry about that config panel and such. :)

Carsten Haitzler (The Rasterman) <raster at>

More information about the community mailing list