Debian on the FreeRunner -- now official

Carsten Haitzler (The Rasterman) raster at
Thu Aug 21 01:44:44 CEST 2008

On Wed, 20 Aug 2008 18:50:57 +0300 Timo Juhani Lindfors <timo.lindfors at>

ok. oops. missed 1 check for system conn. fixed in svn. (segv).
as for trynig illume - you ALSO want the illume profile and thus initial config
setup - so use in the illume svn dir (it runs xephyr for you, sets up
some modmappings for qtopia - not interesting on a desktop unless you have a
desktop x86 build of the qtopia x11 port, and it runs e with the illume

as for accessing keyboard. even if you have the manual button, it will be
disabled.. if you have a usb keyboard plugged in (yes! that code in illume that
detects a physical keyboard like bluetooth and/or usb keyboards plugged in) is
working! :)

luckily for you... there is a config file for that.
you need to put a file in ~/.e/e/keyboards for your desktop to work around it's
default setup as to what "input devices" to ignore (eg ignore build in keyboard
interfaces that dont actually provide a real keyboard):

 9:42AM ~/.e/e/keyboards > cat ignore_built_in_keyboards 

so just make a file that has that. you'll notice illume ships with one for the
"system" that is:

 9:43AM ~ >
cat /usr/local/lib/enlightenment/modules/illume/keyboards/ignore_built_in_keyboards /org/freedesktop/Hal/devices/platform_*

so this ignores things like ps/2 and at keyboards, but usb keyboards are
"removable device" style keyboards and thus disable the vkbd :)

> Hi,
> [Cc'ing to illume author.]
> Daniel Benoy <daniel at> writes:
> > Is there an ETA on illume being packaged?
> > Is there anything that can be done to help?
> I compiled e17 svn head and illume using
> on my debian unstable chroot but
> Configuration -> Modules -> Illume -> Load Module
> just prints
> Have you managed to get compile illume? GDB shows that it crashes at
> #0  0xb7ac8d1a in e_dbus_message_send (conn=0x0, msg=0x814ef20,
> #cb_return=0xb7ac8c30 <cb_method_call>, timeout=-1, data=0x0) at
> #e_dbus_message.c:70 1  0xb7ac8dd9 in e_dbus_method_call_send (conn=0x0,
> #msg=0x814ef20, unmarshal_func=0, cb_func=0, free_func=0, timeout=-1,
> #data=0x0) at e_dbus_message.c:115 2  0xb6e6180d in _system_req_state
> #(state=0xb6e74809 "on") at e_pwr.c:87 3  0xb6e6161a in e_pwr_init () at
> #e_pwr.c:27 4  0xb6e550ca in e_modapi_init (m=0x821d220) at e_mod_main.c:46
> #5  0x080ae7a6 in e_module_enable (m=0x821d220) at e_module.c:265 6
> #0x080f0236 in _mod_hash_load (hash=0x85c37e0, key=0x85c3e68 "illume",
> #data=0x85c3ea8, fdata=0x0) at e_int_config_modules.c:642 7  0xb7c1a0e3 in
> #evas_hash_foreach (hash=0x85c37e0, func=0x80f0200 <_mod_hash_load>,
> #fdata=0x0) at evas_hash.c:459 8  0x080ef778 in _enable_modules (enable=1) at
> #e_int_config_modules.c:624 9  0x080f0129 in _btn_cb_load (data=0x8339480,
> #data2=0x0) at e_int_config_modules.c:594 10 0x080d8689 in
> #_e_wid_activate_hook (obj=0x86d2c20) at e_widget_button.c:164 11 0xb7ecad39
> #in edje_match_callback_exec (ppat_signal=0x86de4b8, ppat_source=0x86de098,
> #signal=0x86dd2f8 "e,action,click", source=0x8232610 "", callbacks=0x86bded0,
> #ed=0x86d2e60) at edje_match.c:393 12 0xb7ebf26c in _edje_emit_handle
> #(ed=0x86d2e60, sig=0x86dd2f8 "e,action,click", src=0x8232610 "") at
> #edje_program.c:1009 13 0xb7ec8df2 in _edje_message_process (em=0x8802a18) at
> #edje_message_queue.c:548 14 0xb7ec9567 in _edje_message_queue_process () at
> #edje_message_queue.c:623 15 0xb7ec9653 in _edje_job (data=0x0) at
> #edje_message_queue.c:108 16 0xb7eec752 in _ecore_job_event_handler
> #(data=0x0, type=15, ev=0x873ed58) at ecore_job.c:104 17 0xb7aa793d in
> #_ecore_event_call () at ecore_events.c:429 18 0xb7aaea95 in
> #_ecore_main_loop_iterate_internal (once_only=0) at ecore_main.c:680 19
> #0xb7aaecaf in ecore_main_loop_begin () at ecore_main.c:87 20 0x0806db62 in
> #main (argc=1, argv=0xbfaa9804) at e_main.c:941
> probably because of
> Error connecting to bus: Failed to connect to
> socket /var/run/dbus/system_bus_socket: Connection refused
> My unstable chroot does not have access to dbus outside chroot. After
> sudo mount -o bind /var/run/dbus /sid/var/run/dbus
> I don't see a crash but I can't figure out how to access the
> keyboard. Is there some hotkey to activate it?
> best regards,
> Timo Lindfors

Carsten Haitzler (The Rasterman) <raster at>

More information about the community mailing list