Debian on the FreeRunner -- now official

Timo Juhani Lindfors timo.lindfors at
Thu Aug 21 08:19:07 CEST 2008

Carsten Haitzler (The Rasterman) <raster at> writes:
> setup - so use in the illume svn dir (it runs xephyr for you, sets up
> some modmappings for qtopia - not interesting on a desktop unless you have a
> desktop x86 build of the qtopia x11 port, and it runs e with the illume
> profile).

Thanks. With I get an error which I don't seem to be able to
copy&paste. Screenshot is at

The module in question is in


so I probably need to figure out how to configure E to find it there?

> as for accessing keyboard. even if you have the manual button, it will be
> disabled.. if you have a usb keyboard plugged in (yes! that code in illume that
> detects a physical keyboard like bluetooth and/or usb keyboards plugged in) is
> working! :)
> luckily for you... there is a config file for that.
> you need to put a file in ~/.e/e/keyboards for your desktop to work around it's
> default setup as to what "input devices" to ignore (eg ignore build in keyboard
> interfaces that dont actually provide a real keyboard):
>  9:42AM ~/.e/e/keyboards > cat ignore_built_in_keyboards 
> /org/freedesktop/Hal/devices/*
> so just make a file that has that. you'll notice illume ships with one for the
> "system" that is:
>  9:43AM ~ >
> cat /usr/local/lib/enlightenment/modules/illume/keyboards/ignore_built_in_keyboards /org/freedesktop/Hal/devices/platform_*
> so this ignores things like ps/2 and at keyboards, but usb keyboards are
> "removable device" style keyboards and thus disable the vkbd :)


More information about the community mailing list