Debian on the FreeRunner -- a few questions/solutions

Fox Mulder Quakeman1 at
Mon Aug 25 00:39:39 CEST 2008

Timo Juhani Lindfors wrote:
> Fox Mulder <Quakeman1 at> writes:
>> First thing is that i can't find the setting, when the display dims the
>> brightness. The default setting dims it after some minutes (~3-5 min, i
>> didn't measure it) what is way to late for battery usage. Also it would
> At the moment you need to edit the source:
> 1) apt-get source fso-frameworkd
> 2) edit fso-frameworkd*/framework/subsystems/odeviced/ around line 58
> 3) fakeroot apt-get --build source fso-frameworkd
> 4) dpkg -i fso-frameworkd*deb

I downloaded, edited and compiled it on my neo. I changed the values to

    self.timeouts = { \
                    "IDLE": 1,
                    "IDLE_DIM": 2,
                    "IDLE_PRELOCK": 3,
                    "LOCK": 4,
                    "SUSPEND": 20, \

But i don't really know if these numbers are minutes or something else.
But after installing the new compiled package the result is not exactly
what i hoped for. Within xfce and no thone running the behaviour is the
same as before. Ahen i start zhone the backlight dims after ~25s and
gets complete dark and locks after ~15s more.
I can't figure out what the numbers i changed really do and IF they
really did something or not. :/
But i was hoping to change the behaviour of xfce even when zhone is not
running, what is the condition most of the time at the moment. ;)

>> ne nice to set the maximum brightness and not always maximum (63).
> 1) apt-get source zhone
> 2) edit zhone*/src/zhone around line 1924
> 3) fakeroot apt-get --build source zhone
> 4) dpkg -i zhone*deb

This didn't work at all. When i try to compile it with "apt-get --build
source zhone" i get an error message that some archives couldn't be
downloaded. I only got zhone_0-git20080809.orig.tar.gz and it also wants
the dsc and diff file.
But i think this affects also only the brightness when zhone is running.
Is there a way to change this setting for xfce?

>> Then i wanted to use openoffice, what would make me really happy because
>> i only use OO on my desktop as well. But after i inetalled it i can't
>> start it. When i try to start any OO app i got the following error message
>> /usr/lib/openoffice/program/soffice: line 365:  2088 Illegal instruction
>>     "$sd_prog/$sd_binary" "$@"
>> where the second number increases with every try. "soffice" seems to be
>> a start script, but i can't find the problem why it doesn't work. :(
> You probably should try openoffice under qemu. If you can reproduce it
> there you should file a bug to
>> Then i wanted to ask if there exists a recent navit version for debian.
> You can create a package easily:
> 1) wget
> 2) tar zxf navit-0.0.4.tar.gz
> 3) cd navit-0.0.4
> 4) dh_make -s -f ../navit-0.0.4.tar.gz
> 5) edit debian/rules and change line that calls ./configure to read only
> ./configure $(CROSS) --prefix=/usr
> 6) dpkg-buildpackage -rfakeroot
> 7) sudo dpkg -i ../navit*deb

This works after reinstalling quite some dev packages. I only couldn't
apply the fast-map-dragging patch with the svn version 1314. It seems
some files have changed and the patch didn't apply successfull. But the
programm runs and that is quite some success. :)

I hope that the fast map dragging patch will be applied to the svn
repository soon, so everybody doesn't have to do the patching on their
own when compiling for themselfs. ;)

> This quick'n'dirty packaking took only a few minutes but the package seems to work:
> To create armel package you probably want to
> qemubuilder --build navit_0.0.4-1.dsc
> since building navit on your freerunner might take a while.

Thats's right. The building of navit on my neo takes quite some time.

> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list