Headset state in OM2008.8, QPE version

Nishit Dave stargazer.dave at gmail.com
Tue Aug 26 17:49:57 CEST 2008


I am now using the qpe based call interface.  I have found the following;

If the headset is connected during an ongoing call, the state doesn't change
automatically.  You have to manually select 'speakerphone' from options to
make the headset work.  Even then, sound is heard through one earbud (the
"turn amp speaker off" bug).  The mic in the headset does not work, but the
mic in the phone works as if in the speakerphone mode.

If one were sitting at a desk playing with alsamixer through SSH, it would
be easy to hear sound through both earbuds, but this ideal world scenario is
in direct dissonance with the real world scenario where the headset is
employed while driving.

Further, the myriad options under alsamixer -V all confuse the user
entirely, and do not give a clue as to which value to change so that the
headset mic works.

When the headset is already plugged in (before a call), there is static from
the earbuds, which means it can drain off the battery as there is signal
leakage.  When a call comes in, the headset works automatically, BUT its mic
still does not!

With OM2008.8, I don't see alsamixer -V all show changes in the state files
when the headset is plugged in while in use.  It worked in 2007.2.

Has anybody else been able to replicate this problem? Does one need to file
a bug report for this, or is there an easier solution?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.openmoko.org/pipermail/community/attachments/20080826/e14947ef/attachment.htm 

More information about the community mailing list