Getting rid of echo for callers.

Daniel Selinger slite at
Fri Aug 29 19:46:56 CEST 2008

On Fri, 29 Aug 2008 03:10:39 -0700 (PDT)
Mav <yann.sladek at> wrote:

> Thanks a lot for your trick
> The echo is now gone on Qtopia 4.3.2 and it's really a good news
> As someone said, I can barely hear my correspondant but I guess it's
> only a tune in the gsmhandset.state (I also tried to increase the
> Mono Bypass level to 100 but it's not really improving situation (I
> will try with more than 100)

Yea, i tried these settings in real life conditions today, and also
must admit, that it is too silent for both sides. I think this should
be fixed by taking my original settings, and just putting up 'Speaker
Playback Volume" to about 110 (should make the speaker on the
freerunner louder) and 'Mono Playback Volume' to 90-95 which should
make oneself louder for the other side. (Yes i know that sounds silly
as the control is called Playback Volume, but that is what i recognized
yesterday, lowering Mono Playback makes us more silent for the other
person. Have to confirm this again but i'm quite sure)

I just do this from memory, i will do my tests this tomorrow.

I think some repeating tuning will be nesecarry to fit every condition,
and maybe some echo isn't avoidable until we have more advanced
techniques to get rid of it.

But in my case this is a more than good improvement compared to default

More information about the community mailing list