Media player

Dylan Reilly dreilly at
Sat Aug 30 18:29:55 CEST 2008

There are several tricks to getting the qtopia media player to find your
music properly.

1) Your  music must be located in one of the paths defined in
/opt/Qtopia/etc/default/Trolltek/Storage.conf (or something similar, I do
not have my device at the moment). By default those are only /home and the
*first* partition of the SD card. You can edit Storage.conf to your liking
but will have to restart X to get it to start reading the new file systems.

2) There seems to be a problem with both media players where they will fail
to properly read files (id3 tags and playing) when your files are either
stored not on the first partition of the SD card, or if the partition is not
formatted as FAT. I say either because I have not tested further to discover
which is the real culprit.

As to the qtopia media player being slow, it is only slow the first time it
loads per device boot. It seems to do much reading and caching the first
time through. If you keep it up for a while the experience improves

Finally, there is still a issue with pulse audio suspending. If you have a
stream open through pulseaudio when you resume pulseaudio will be "locked"
and nothing will play. One might be able to rectify this by killing
qtopia-mediaserver after suspend but I have not tested that. If in doubt,
turn off suspend before playing music.

On Sat, Aug 30, 2008 at 12:07 PM, Bastian Muck <bastian.muck at> wrote:

> Hash: SHA1
> Michael Zanetti schrieb:
> > On Saturday 30 August 2008 17:43:26 Thomas Bertani wrote:
> >
> >> ehm... I copied in a folder (called "sounds" a mp3 song to
> >> /home/root/Documents/, I restarted X but the qtopia-x11 media player is
> >> empty... it doesn't show my mp3 file... how do you used it exactly?
> (sorry
> >> for my bad english)
> >
> > I cannot retry it at the moment because my Openmoko currently is a
> BrokenMoko
> > (See my other thread in this list). But I'm fairly sure I did that like
> I sad
> > before. Perhaps you could try a reboot to make the Media Player
> recognize the
> > tracks.
> >
> > _______________________________________________
> > Openmoko community mailing list
> > community at
> >
> >
> I can confirm that this works. But the media players seems not to read
> the ID3-Tag. An it isn't usable. You can hear half a second and then
> you have half a second break. But it can "play" mp3
> Greetings Bastian
> Version: GnuPG v1.4.7 (MingW32)
> Comment: Using GnuPG with Mozilla -
> =Ebw5
> _______________________________________________
> Openmoko community mailing list
> community at

Dylan Maxwell Reilly
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the community mailing list