2008.8: Enlightenment crashing at bootup after upgrade

Thomas Köckerbauer tkoeck at gup.jku.at
Sun Aug 31 20:43:58 CEST 2008


Sorry that I'm not replying in the thread, but I don't have the original mail 

I have the same problem, since I updated today enlightenment crashes with 
SIGSEV every time when it starts (I can see the gadget icons, but the 
application icons do not yet show up).
I've installed the debug version, attached a debugger and got the backtrace of 
the segfault, here it is:

Program received signal SIGSEGV, Segmentation fault.
0x404e1ce4 in strlen () from /lib/libc.so.6
(gdb) bt
#0  0x404e1ce4 in strlen () from /lib/libc.so.6
#1  0x404b3400 in _IO_vfprintf_internal (s=0xbe9ece80, 
format=0x400f6488 "%s %s %s", ap=<value optimized out>) at vfprintf.c:1568
#2  0x404d43d8 in _IO_vsnprintf (string=0xbe9ecfa8 "hicolor battery ", 
maxlen=4096, format=0x400f6488 "%s %s %s", args=0xbe9ecf9c)
    at vsnprintf.c:120
#3  0x404b9fd0 in __snprintf (s=0x30 <Address 0x30 out of bounds>, maxlen=48, 
format=0x19aaf8 "battery") at snprintf.c:35
#4  0x400ea264 in efreet_icon_path_find (theme_name=0x11a248 "hicolor", 
icon=0x19aaf8 "battery", size=0x30 <Address 0x30 out of bounds>)
    at efreet_icon.c:342
#5  0x0005f060 in e_util_icon_theme_icon_add ()
#6  0x000ad018 in e_fm2_icon_get ()
#7  0x000ad5d4 in _e_fm2_icon_icon_direct_set ()
#8  0x000adc44 in _e_fm2_icon_realize ()
#9  0x000addac in _e_fm2_regions_eval ()
#10 0x000ae008 in _e_fm2_regions_populate ()
#11 0x000ae158 in _e_fm2_cb_resize_job ()
#12 0x400947f8 in _ecore_job_event_handler () from /usr/lib/libecore_job.so.0
#13 0x404204a0 in _ecore_event_call () from /usr/lib/libecore.so.0
#14 0x40426fa8 in _ecore_main_loop_iterate_internal () 
from /usr/lib/libecore.so.0
#15 0x4042701c in ecore_main_loop_begin () from /usr/lib/libecore.so.0
#16 0x00029b78 in main ()

I did not have a closer look yet, but maybe raster already has an idea ;)


More information about the community mailing list