Optimization team update (11/23 ~ 11/29)

John Lee john_lee at openmoko.com
Mon Dec 1 06:51:24 CET 2008

On Sun, Nov 30, 2008 at 02:16:48PM +0100, Franky Van Liedekerke wrote:
> On Sun, 30 Nov 2008 19:50:22 +0800
> John Lee <john_lee at openmoko.com> wrote:
> > Echo:
> > 
> > Since there are different hw versions out there (a5, a6, a7), it's
> > impossible to provide one alsa state file that suits all models.
> > However, it seems you can always find appropriate values for your
> > neo.  My way is to adjust
> > control.4 Speaker Playback Volume in
> > /usr/share/openmoko/scenarios/gsmhandset.state
> > 
> > the max value is 127, 95 works best on my a5.  With volume level 3 or
> > 4 in qtopia dialer, the other side can hear no echo while I get good
> > audio quality.
> Does this mean the fix is only through alsa? So the fix mentioned here:
> http://n2.nabble.com/FSO-M4---nice-GSM-sound-tp1486414p1518726.html
> is not ok? Since that fix is the only real fix for my echo issues (and
> it seems to come from 2008.8).
> Franky

That fix is already in testing repo, maybe over 1 month now.  However
even with this patch there is still chance you can hear echo.

Let's say A calls B, and B is using a neo with this fix.

1. The receiver (handset speaker) is loud enough and the mic is
   sensitive enough, so gsm won't turn off the mic.

2. A starts speaking right after B, but gsm needs a little time to turn
   off mic.

In either case you can still here a little echo.  Much better then
before, of course, but still a little.  I was talking about 1. in my
previous post.

- John

More information about the community mailing list