mplayer with glamo and audio - very slow

Leonti Bielski prishelec at
Wed Dec 3 03:38:45 CET 2008


I'm trying to play some video preencoded for my phone with:
mencoder file_to_encode.avi -ovc lavc -lavcopts
vcodec=mpeg4:vhq:vbitrate=300 \ -vf
scale=320:240,eq2=1.2:0.5:-0.25,rotate=2 -oac mp3lame -lameopts
br=64:cbr \ -o

To watch it I run:
mplayer -vo glamo -zoom -x 480 -y 640 your_file.avi

It is played very slow and I get message from mplayer - "your system
is very slow" or something like that.
Than I tried it with -nosound option - and I don't get that message
and the fps seem acceptable.
I've always though video was an issue, but this shows me that audio
can significantly slow down the playback.

Should I encode my video differently?
Or something else is wrong?


More information about the community mailing list