mplayer with glamo and audio - very slow

Pierre Lascar openmoko at
Wed Dec 3 13:43:26 CET 2008

Le 03/12/2008 03:38, Leonti Bielski a écrit :
>  Hello!
>  I'm trying to play some video preencoded for my phone with: mencoder
>  file_to_encode.avi -ovc lavc -lavcopts vcodec=mpeg4:vhq:vbitrate=300
>  \ -vf scale=320:240,eq2=1.2:0.5:-0.25,rotate=2 -oac mp3lame
>  -lameopts br=64:cbr \ -o file_for_openmoko
>  To watch it I run: mplayer -vo glamo -zoom -x 480 -y 640
>  your_file.avi
>  It is played very slow and I get message from mplayer - "your system
>  is very slow" or something like that. Than I tried it with -nosound
>  option - and I don't get that message and the fps seem acceptable.
>  I've always though video was an issue, but this shows me that audio
>  can significantly slow down the playback.

Hi !
I'm having the same trouble, encoding in qPAL as stated for glamo 
decoding, with the following options:
mencoder in.avi -ovc lavc -lavcopts vcodec=mpeg4:vhq:vbitrate=300 
-ffourcc mp4v -vf scale=352:-2,expand=352:288,eq2=1.2:0.5:-0.25,rotate=2 
-oac mp3lame -lameopts br=64:cbr -o out.avi

Whe playing the file with nosound (and no zoom), top shows a very low 
CPU% from mplayer (2-5
at most) so the chip is used, but when the sound gets involved, 
framerate drops and the sound is not syncronised. (everything done from 
flash, not the microsd, so the bandwith stufff shouldn't mess).

Maybe the problem comes from frame/sound sync in the glamo driver.


More information about the community mailing list