First impressions on new Android rootfs

Rui Castro rui.castro at
Thu Dec 4 04:38:53 CET 2008


My first impressions on this new image is that it isn't usable :)

My keyboard has some obvious problems, the letter/number/symbols keys
are too small and when dialog windows appear asking for text, like the
bluetooth pairing code, the keyboard is bellow the dialog and cannot
be clicked. I have to work on those issues.

I have been able to boot with kernels uImage-android and
uImage-tracking, but both are very unstable. The suspend/resume don't
work reliably in any of them. With uImage-tracking, the only one I
could get to work for some time, bluethooth works, gsm works
sometimes, wifi works but it doesn't detect my wireless network (WPA)
and it doesn't shutdown.

The workaround to boot the uImage-tracking kernel from uBoot (setenv
bootcmd setenv ... ; saveenv) works, but when I poweroff neo and try
to boot again it doesn't work anymore; I have to do the hack again.
Maybe I'm doing something stupid here. It's the first time I mess with
uBoot shell.

I tried to make a jffs2 image from koolu source code, but I had no
luck. I compiled the sources successfully with "make
PRODUCT_TARGET=freerunner", then I tried to create a jffs2 image
following a very simplistic and probably wrong approach:

1. Created a directory newandroidfs,
2. Extracted the contents of out/target/product/freerunner/ramdisk.img
to that directory, using file-roller,
3. copied the files under out/target/product/freerunner/system to /system,
4. created a symlink /etc to /system/etc and a directory /sdcard (like
I saw in Sean's image)
5. and created a jffs2 image with the contents of the directory
newandroidfs using the command "mkfs.jffs2 --pad=0x700000 -o
newandroidfs.jffs2 -e 0x20000 -n -dnewandroidfs/"

Outcome of all this, red light flashing!!! It's kernel panic, right? :(

If someone (have no ideia who :) ) did a simple tutorial about how to
produce the precious jffs2 image, that would make the testing of new
features a lot simpler.

Well, I'm sure we will have a working image to show off the new phone
on the weekend ;)


On Thu, Dec 4, 2008 at 12:23 AM, "Marco Trevisan (Treviño)"
<mail at> wrote:
> Gothnet wrote:
>> But editing the bootcmd entry to read a larger kernel "nand read.e
>> 0x32000000 kernel 0x300000;" then flashing the kernel and rootfs image as
>> usual. Unfortunately the time I took to do this seems to have run down the
>> freerunner's battery, and now android boots and immdeiately says "shutting
>> down" because of low power. It doesn't do it though.
> If you've used the stable-tracking kernel, maybe this is due to the
> userspace /sys battery node changes. See on previous mail how to fix this.
> --
> Treviño's World - Life and Linux
> _______________________________________________
> Openmoko community mailing list
> community at

More information about the community mailing list