[u-boot] Environment garbled after setenv?

Joachim Breitner nomeata at debian.org
Sun Dec 7 20:24:13 CET 2008


Am Sonntag, den 07.12.2008, 21:07 +0300 schrieb Evgeniy Karyakin:
>     I see it as environment broken and afraid to say "saveenv" which can 
> make this uncertain state permanent. What can it be, have anybody seen this?

In fact, I have. I observed this when I was trying to modify the uBoot
environment from the device, in the Debian installer. I wanted to
provide a way to completely do the installation from on the device. But
after my changes, I have seen the problems that you have, so I wrote the
configure-uboot.sh script.

You can still see my work in the debian installer, by running
$ ./install.sh uboot
which runs the code (it is not normally run by ./install.sh all).

If it turns out that the reason was just pure accident (or something),
and not the fact that I was modifying from on the device, we could
enable this and make the Debian installation even easier.

Test reports appreciated!


Joachim "nomeata" Breitner
Debian Developer
  nomeata at debian.org | ICQ# 74513189 | GPG-Keyid: 4743206C
  JID: nomeata at joachim-breitner.de | http://people.debian.org/~nomeata
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url : http://lists.openmoko.org/pipermail/community/attachments/20081207/a84207a3/attachment.pgp 

More information about the community mailing list