[SHR] network link down on windows after opkg update

Thomas B tommy.b at gmx.net
Mon Dec 15 13:45:47 CET 2008

On Mon, Dec 15, 2008 at 11:41:01AM +0100, KaZeR wrote:
> Hi everyone.
> I ran opkg update && opkg upgrade this morning. I saw a new kernel was
> installed, so i rebooted the phone.
> After reboot, windows sees the usb device, but no link..
> I'm currently not at home, so i only have access to a windows computer.
> Anything i could do to try to get back access to my FR?
> Anyone else has the same issue?

Yep, had the same issue. I noticed that networking wasn't started at
boot anymore after an okpg upgrade. Try to open the terminal on the FR
and do "ifup usb0" to bring up USB networking manually.

I think the reason for this issue is a change in the initscripts. I
fixed it by forcing an install of the package initscripts-shr as a
replacement for initscripts (opkg hadn't done that automatically,
because the difference in versioning made it look like a downgrade).


More information about the community mailing list