Trying to get support for some Neo setup problems...

john dowd jdowdster at
Wed Dec 17 15:01:57 CET 2008

Thanks for the reply Sarton,
I'm in the process now of flashing in another load onto the Neo. I
have the SD card that came with the Neo. I'm running from FLASH right
now. I never put a load on the SD.

I'm not so sure I would accuse the boot loader unless there's
something you know that I don't. The system does start to boot but it
fails somewhere along the way. The kernel is loading but fails while
loading modules I think. I noticed that when it has stopped writing to
the console I can then plug in or remove the USB cable and I get the
usual module load/unload output to the console. I'm beginning to
suspect that the X server is dying. Unfortunately, I can't get at the
device through a console to muck about with it.


On Tue, Dec 16, 2008 at 6:05 PM,  <roguemoko at> wrote:
> john dowd wrote:
> [SNIP]
>> My point is that without modifying files on my Neo, it starts to
>> behave differently.
>> I have even more strange behaviour to report. After several reboot
>> attempts (but no modifications to the Neo) it suddenly booted properly
>> and I was up and running again. This was true for the last few hours.
>> Now, it just started to behave badly once again. I am still testing my
>> Access Point and the Neo gets "booted" quite a few times. its plugged
>> into the power supply. Since I want the Neo to come up on its own I
>> don't use the power switch/Gui to turn it off. I bring up a terminal
>> and type in "reboot".
> Ah ... are you running from SD Card already or from flash?
> This sort of behaviour is typical of unsupported SD Cards. If you are
> running from SD, what size is it? There are some tricks to get some
> cards working but I have had success with all 2GB cards.
> If you are running from nand, all I could suggest is a u-boot upgrade.
> Outside of that maybe there are hardware issues?
> Sarton
> _______________________________________________
> Openmoko community mailing list
> community at

                              John Dowd
                              jdowd at
                              133 Waverley St.
                              Ottawa Ont. K2P 0V3
                              Home: (613)234-7884
                              Cell: (613)316-7884

More information about the community mailing list