Trying to get support for some Neo setup problems...

john dowd jdowdster at
Thu Dec 18 16:32:05 CET 2008

Well, I flashed my Neo with the Om2008.9-gta02-20081106 image and
jffs2 file system and I have a phone that boots once again. In fact I
have it fully functional with my original target of an automatic wifi
connection using WPA2 encryption to my Access Point. I'm running a
laptop with hostapd and a USB wireless Dongle configured to be the
wireless access point. I'm building my system out of experimental
parts as a demo for my customer.

On the laptop I have:
2.6.28-rc5 kernel (experimental)
USB Wireless Dongle driver rt2x00usb (experimental and I had to hack it)
hostapd Appilcation (release 0.6.6... experimental)
Asterisk - open source PBX application

I was using a Nokia e71 wifi and SIP enabled phone to connect to the
access point that I had created but it would not see the SSID of my
Access Point. This worried me since I had created it all on bleeding
edge s/w and perhaps I had bled myself into a corner but, when I
checked, all other devices could at least see my access point. I just
happened to have been given a Neo Freerunner by the customer as well
for "future" work. Well, it had 3 obvious advantages over the Nokia

1. I could get at the s/w on it.
2.  It Moos when it flips over.
3. Thanks to the ground breaking work of Carlo Menucci, it sends good vibes!!

The last step is now before me, I need to get a SIP phone to work on
the Neo (that's why the customer had originally chosen the e71, its a
SIP enabled phone). There seems to be 2 available for the Neo but both
present me with problems. The SIP phone called "Twinkle" is only
available on the Debian distro. The SIP phone called "Linphone" seems
to have some library issues.

Is there an easy way of porting a Debian package to the opkg format?
Can the library issues with "Linphone" be easily solved? The errors I
see when I try to install it as per the instructions on the "Linphone"
page is:

root at om-gta02:/etc/opkg# opkg update
parseVersion: ERROR: epoch in version is not numberparseVersion:
ERROR: epoch in version is not numberparseVersion: ERROR: epoch in
version is not numberparseVersion:
ERROR: epoch in version is not numberDownloading

this goes on for quite some time.


On Tue, Dec 16, 2008 at 6:56 PM,  <roguemoko at> wrote:
> Konstantin wrote:
>> roguemoko at schrieb:
>>>> [  204.715000] PM:Removing info for No Bus:vcs2
>>>> [  204.720000] PM:Removing info for No Bus:vcsa2
>>>> Essentially the Neo is now a brick. I'm wondering where to go from
>>>> here. I have installed 2008 version of the s/w on the phone.
>>> Unfortunately without the exact steps you took to get into this
>>> situation, we're unable to determine the correct steps to get you out.
>>> The most generic answers would be:
>>> 1). Reflash with your preferred distribution.
>>> 2). Boot from SD Card, access the flash memory and correct your mistake.
>>> Although I'm not sure if '2)' is possible as I've never tried. I've only
>>> ever come in from the other direction (modify SD from flash).
>>> Potentially, if it is simply the x server not starting, you may still be
>>> able to ssh in via usb and correct your mistake.
>> I *might* just have the same problem. I tried opkg-upgrading my FDOM (OM2008.9)
>> to testing, and now booting stops with the same messages the original poster has
>> seen, plus the same vor vcs1 and vcsa1. Haven't found a way to fix this,
>> unfortunately, as ssh doesn't seem to be running. The kernel however is still
>> alive, responds to pings and prints out information about the changed power
>> state when plugging in the charger or the usb cable.
> It's really hard to say. I know first hand that an opkg upgrade to
> testing can cause this. The original poster was having other issues
> aswell however.
> I'd say if your problems aren't intermittent then you may just have a
> bad upgrade. I'm tempted to think the dropbear problem is back aswell,
> as I overwrote all config files, the default a while back prevented ssh
> access except for localhost? or something silly. I remember having to
> modify the startup script via the om terminal app. Either way, I think
> using a testing image before opkg upgrading via testing is probably a
> better option. I haven't tried the FDOM script ... at all ... or FDOM
> for that matter ... but I imagine it would apply to testing?
> Sarton
> _______________________________________________
> Openmoko community mailing list
> community at

                              John Dowd
                              jdowd at
                              133 Waverley St.
                              Ottawa Ont. K2P 0V3
                              Home: (613)234-7884
                              Cell: (613)316-7884

More information about the community mailing list